1.
Составьте программу вычисления в массиве с(15) произведения элементов ,кратных 9
2.составьте программу вычисления в массиве b(25) среднего арифметического с нечетными числами
1)
var
c:array [1..15] of integer;
i,n:integer;
Begin
n:=1;
randomize
;for i:=1 to 15 do
c[i]:=random(50);
for i:=1 to 15 do
write(c[i], );
for i:=1 to 15 do
if c[i] mod 9=0 then
n:=c[i]*n;
writeln;
for i:=1 to 15 do
write(c[i], );
writeln;
writeln(n);
End.
2)
var
b:array [1..25] of integer;
i,,j:integer;
cr:real;
Begin
randomize;
for i:=1 to 25 do
b[i]:=random(50);
for i:=1 to 25 do
write(b[i], );
for i:=1 to 25 do
if b[i] mod2<>0 then
Begin
cr:=cr+b[i];
j:=j+1;
end;
cr:=cr/j;
writeln;
write(cr);
End.
-----------------Не забудьте сказать спасибо-----------------------
Оцени ответ
