Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру
входные данные
5
выходные данные
101
входные данные
-14
выходные данные
-1110
Procedure Dec2Bin(n: longint; var s: string);
var
z: string;
d: char;
begin
s := ;
if n < 0 then z := - else z := ;
n := abs(n);
while n > 0 do
begin
if (n mod 2) = 0 then d := 0 else d := 1;
s := d + s;
n := n div 2
end;
s := z + s;
if s = then s := 0
end;
var
n: longint;
s: string;
begin
Write(Введите целое число: ); Readln(n);
Dec2Bin(n, s);
Writeln(s)
end.
Тестовое решение:
Введите целое число: -14
-1110
Оцени ответ
