Ребят завтра диагностика! Помогите пожалуйста !!!
16.Автомат получает на вход четырёхзначное десятичное число. По
полученному числу строится новое десятичное число по следующим
правилам.
1. Вычисляются два числа – сумма первой и второй цифр и сумма третьей и
четвёртой цифр заданного числа.
2. Полученные два числа записываются друг за другом в порядке неубывания
(без разделителей).
Пример. Исходное число: 2177. Поразрядные суммы: 3, 14. Результат: 314.
Определите, сколько из приведённых ниже чисел может получиться
в результате работы автомата.
1915 20 101 1213 1312 312 1519 112 1212
В ответе запишите только количество чисел.
10.Известная авиакомпания заносила данные о количестве утерянного багажа за
год в таблицу Lose. Всего были занесены данные за последние 10 лет
работы компании (Lose[1] – количество утерянного багажа за первый год
работы, Lose[2] – за второй год и т. д.). Определите, какое число будет
напечатано в результате работы следующей программы. Текст программы
приведён на трёх языках программирования.
Алгоритмический язык !!!
алг
нач
целтаб Lose[1:10]
цел t, m
Lose[1] := 1; Lose[2] := 5
Lose[3] := 3; Lose[4] := 6
Lose[5] := 7; Lose[6] := 12
Lose[7] := 1; Lose[8] := 3
Lose[9] := 3; Lose[10] := 1
m := 0
нц для t от 1 до 10
если Lose[t] > 3 то
m := m + Lose[t]
все
кц
вывод m
кон
Бейсик!!
DIM Lose(10) AS INTEGER
DIM t,m AS INTEGER
Lose(1) = 1: Lose(2) = 5
Lose(3) = 3: Lose(4) = 6
Lose(5) = 7: Lose(6) = 12
Lose(7) = 1: Lose(8) = 3
Lose(9) = 3: Lose(10) = 1
m = 0
FOR t = 1 TO 10
IF Lose(t) > 3 THEN
m = m + Lose(t)
END IF
NEXT k
PRINT m
Паскаль!
Var t, m: integer;
Lose: array[1..10] of integer;
Begin
Lose[1] := 1; Lose[2] := 5;
Lose[3] := 3; Lose[4] := 6;
Lose[5] := 7; Lose[6] := 12;
Lose[7] := 1; Lose[8] := 3;
Lose[9] := 3; Lose[10] := 1;
m := 0;
For t := 1 to 10 Do
If Lose[t] > 3 Then
Begin
m := m + Lose[t];
End;
Writeln(m);
End.
9.Запишите значение переменной u, полученное в результате работы
следующей программы. Текст программы приведён на трёх языках
программирования.
Алгоритмический язык !!!
алг
нач
цел u,i
u := 30
нц для i от 1 до 6
u := u – i
кц
вывод u
кон
Бейсик!!!
DIM i,u AS INTEGER
u = 30
FOR i = 1 TO 6
u = u – i
NEXT i
PRINT u
Паскаль!!
Var u,i: integer;
Begin
u := 30;
For i := 1 to 6 do
u := u – i;
Writeln(u);
End.
7.Дима хотел послушать музыку на компьютере, для этого ему нужно было
включить музыкальный файл Белые_розы.mp3. Он начал работу с каталога
С:МузыкаХиты. Сначала он спустился на один уровень вниз, в каталог
Ретро, затем поднялся на один уровень вверх, потом спустился на один
уровень в каталог Лучшие и нашёл там нужный музыкальный файл.
Запишите полный путь к данному файлу.
1) С:МузыкаХитыЛучшиеБелые_розы.mp3
2) С:МузыкаБелые_розы.mp3
3) С:Белые_розы.mp3
4) С:МузыкаХитыРетроБелые_розы.mp3

7. 1) С:МузыкаХитыЛучшиеБелые_розы.mp3
9. u:=9

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку