Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное. Была
написана следующая программа:
var a, b: integer;
begin
readln(a, b);
a := a mod 2;
if a > 0 then b := b mod 2;
if b > 0 then
writeln (четных чисел нет)
else
writeln (четное число есть);
end.
Известно, что программа написана с ошибками. Последовательно выполните три задания:
укажите, как, по вашему мнению, нужно доработать программу (не используя слож-ные условия), чтобы не было случаев ее неправильной работы;

Var
a,b:integer;
Begin
readln(a,b);
if a mod 2= 0 then writeln(есть чётное)
else if b mod 2=0 then writeln(есть чётное) 
else writeln(Нет чётных);
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку