Составьте блок-схему и напишите программу вычисления площади и гипотенузы прямоугольного треугольника, если известны его катеты.
Var
a,b,c,z,p,r:real;
begin
writeln (Введите катет А );
readln (a);
writeln (Введите катет B );
readln (b);
z:=sqr(a)+sqr(b);
c:=sqrt(z);
writeln (Гипотенуза равна ,c);
p:=(a+b+c)/2; {по формуле Герона нахожу полупериметр}
r:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln (Площадь треугольника равна --> ,r);
end.
надеюсь блок схема понятна
Оцени ответ
