Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс. Протес-тировать программу для следующих исходных данных:
а) A=3, B=4, C=5
б) A=1, B=1, C=1
в) A=0, B=4, C=5
г) A=-3, B=6, C=5
д) A=2, B=1, C=8
Program a_1;
var A,B,C:integer;
begin
writeln(Введите стороны треугольника);
readln(A,B,C);
if (A+B>C) and (A+C>B) and (C+B>A)
then
begin
writeln(Треугольник существует);
writeln;
end
else
writeln(Треугольник не существует);
writeln;
end.
Оцени ответ
