Номер 6. Составьте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов( по программе Паскаль ) ПОМОГИТЕ ПОЖАЛУЙСТА !!!!

Uses crt;
var a,b,c:integer;
d,x1,x2:real;
begin
clrscr;
writeln(Программа для решения квадратных уравнений!);
write(Введите коэффициент при x^2 );
readln(a);
write(Введите коэффициент при x );
readln(b);
write(Введите свободный член );
readln(c);
d:=b*b-4*a*c;
if (d>0) then
begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write(Уравнение имеет 2 корня: );
writeln(X1=,x1:4:2);
writeln(X2=,x2:4:2);
end
else if (d=0) then
begin
x1:=-b/(2*a);
write(Уравнение имеет 1 корень: );
writeln(X=,x1:4:2);
end
else
writeln(Уравнение корней не имеет(ну если интересно имеет только в комплексной форме записи));
readln;
end

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку