Напишите рекурсивную функцию, возводящую число a в степень n. Гарантируется, что все числа "помещаются" в стандартные вещественные (a и ответ) и целые (n) типы.
Входные данные
Вводится 2 числа - a и n (число n может быть отрицательным).
Выходные данные
Необходимо вывести значение an
Примеры
входные данные
2 -1
выходные данные
0.5

Var  a,f: real;  n,i,g: integer;begin  read(a,n);  if n<0 then begin   g:=n;   n:=-n;  end;  f:=1;  for i:=1 to n do   f:=a*f;  if g<0 then write(1/f)  else write(f);  readln;  readlnend. 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку