Составьте программу которая по трем введенным вами числам определить, могут ли эти числа быть длинами сторон треугольника, и если да ,то определить вид треугольника. помогите

Program v1;
var a,b,c: real;
begin
readln (a,b,c);
If c > a+b then writeln ( Такого треугольника не существует);
If a > c+b then writeln ( Такого треугольника не существует);
If b> a+c then writeln ( Такого треугольника не существует);
If a=b and a=c  then writeln (Этот треугольник равносторонний);
If a=b or a=c or b=c then writeln (Этот треугольник равнобедренный);
If a = scrt ( b*b + c*c) then writeln (Этот треугольник прямоугольный);
If b = scrt (a*a + c*c) then writeln (Этот треугольник прямоугольный);
If c = scrt (a*a + b*b) then writeln (Этот треугольник прямоугольный);
end. 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку