Составьте программу нахождения наибольшего общего делителя трех чисел, используя следующую формулу:
НОД(А, B, С) = НОД(НОД(A, В), С).
Используя алгоритм Евклида.

Function NOD(a, b: longint): longint;
begin
  while a <> b do
    if a > b then a := a - b
    else b := b - a;
  NOD := a
end;

var
  A, B, C: longint;

begin
  Write(Введите три натуральных числа: ); Readln(A, B, C);
  Writeln(НОД=, NOD(NOD(A, B), C))
end.

Тестовое решение:
Введите три натуральных числа: 256 48 24
НОД=8


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку