Вычислить сумму натуральных чисел от 1 до N .
Составить программу нахождения кол-ва делителей числа N ( значение N вводится с клавиатуры )
Держи!
1)
var i,n,result:integer;
begin
read(n);
result:=0;
for i:=1 to n do
begin
result:=result+i;
end;
write(result);
end.
2)
var i,n,increase,result:integer;
massive = array[1..1000] of integer;// ищем делители в диапазоне 1-1000
begin
read(n);
for i:=1 to 1000 do
begin
if((n mod massive[i])=0) then
begin
increase:=increase + 1;
end;
end;
result:=increase;
write(result);
end.
Оцени ответ
