Напишите программу, которая в последовательности натуральных чисел
определяет сумму всех чисел, кратных 4 и оканчивающихся на 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 4 и оканчивающихся на 8.
Begin
var count := 0;
var sum := 0;
while True do
begin
var a := ReadInteger;
Assert(a <= 300);
count += 1;
Assert(count <= 100);
if a = 0 then
break;
if (a mod 4 = 0) and (a mod 10 = 8) then
sum += a;
end;
Writeln(Сумма чисел по предикату равна , sum);
end.
Оцени ответ
