Составить программу которая вводит с клавиатуры координаты точек на плоскости и определяет принадлежность точки зашрихованной области включая её границы

Условия y≤-x при x≤0  и y≤x при x>0 можно объединить в одно: y≤|x|

var
  x, y: real;

begin
  Write(Введите координаты точки на плоскости: );Readln(x, y);
  if (y <= abs(x)) and (y >= sqr(x) - 3) then
    Writeln(Точка принадлежит заштрихованной области)
  else
    Writeln(Точка не принадлежит заштрихованной области)
end.

Тестовое решение:
Введите координаты точки на плоскости: -1.15 -1.24
Точка принадлежит заштрихованной области


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку