помогите пожайлуста)))))))))))
Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.
ввод:1, 1, 1, 2, 2, 2
вывод: 3661
ввод:1,2,30,1,3,20
вывод: 50
это задача на pascal ABC
Program Pr1;
uses crt;
var ch,min,sek,ch2,min2,sek2,a,b,c:integer;
Begin
clrscr;
a:=0;
b:=0;
readln(ch,min,sek,ch2,min2,sek2);
while a<=ch do begin
a:=a+1;
b:=b+3600;
c:=b;
end;
b:=b+min*60+sek;
while a<=ch2 do begin
a:=a+1;
c:=c+3600;
end;
c:=c+min2*60+sek2;
writeln(c-b);
end.
