Написать программу, в которой пользователь выбирает одну из предметных областей:математика или география. Если выбрана математика-компьютер по порядку задает три примера на вычисление (например: 4+3=?). Если выбрана география-компьютер спрашивает столицы трех государств. Компьютер проверяет ответы на правильность и в конце выводит оценку на экран:5-если не было ошибок, 4-одна ошибка, 3-две ошибки, 2-если все ответы неверные.
Помогите пожалуйста, заранее благодарю.
Var a,b,c,z,x,h,count:integer;
q,w,e,r,t,y,k:string;
begin
a:=99;
b:=81;
c:=63;
q:=Берлин;
w:=Москва;
e:=Бразилиа;
writeln(Выбери предмет);
writeln(математика или география );
read(k);
case k of
география : begin
readln;
write(Столица Германии это );
read(r);
readln;
writeln;
write(Столица России это );
read(t);
readln;
writeln;
write(Столица Бразилии это );
read(y);
readln;
writeln;
end;
математика : begin
write(11*9=);
read(z);
writeln;
write(9*9=);
read(x);
writeln;
write(7*9=);
read(h);
writeln;
end;
end;
if q=r then count:=count+1;
if w=t then count:=count+1;
if e=y then count:=count+1;
if a=z then count:=count+1;
if b=x then count:=count+1;
if c=h then count:=count+1;
if count=0 then writeln(Твоя оценка по предмету ,k, это только 2);
if count=1 then writeln(Твоя оценка по предмету ,k, это только 3);
if count=2 then writeln(Твоя оценка по предмету ,k, это только 4);
if count=3 then writeln(Твоя оценка по предмету ,k, это только 5);
end.
