Паскаль абц
Ввести несколько чисел. Вывести числа от 20 до 75, кратные 4

Var N, i: integer; // N - переменная хранения количества чисел, которое введет пользователь
A: array[1..20] of integer; // массив, содержащий САМИ ЧИСЛА, которые введет пользователь 
begin
write(Сколько чисел вы собираетесь ввести? );
readln(N); 
for i := 1 to N do begin
write(Введите , i, число: ); // ввод чисел
readln( A[ i ] );
end;
write(Из них числа от 20 до 75, кратные 4: );
for i := 1 to N do begin
if ( A[ i ] >= 20 ) and ( A[ i ] <= 75 ) then // проверяем в каком промежутке лежит число
if ( ( A[ i ] mod 4 ) = 0 ) then write( A[ i ], ); // если число меньше 75 и больше 20, тогда проверяем кратно ли оно четырем. Если да, то выводим его
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку