Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.
Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести слово YES, если существует пара соседних элементов с одинаковыми знаками. В противном случае следует вывести слово NO.
Примеры
Входные данные
5
1 -3 4 -2 1
Выходные данные
NO

Const
n=10000;
var
a:array[1..n]of integer;
i,n1, flag:integer;
begin
    readln(n1);
        for i:=1 to n1 do
             read(a[i]);
for i:=1 to n1-1 do
   if ((a[i]<0)and(a[i+1]<0))or
      ((a[i]>0)and(a[i+1]>0))then
                flag:=1;
if flag=1 then
    writeln(YES)
 else
    writeln(NO);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку