Составить программу вычисления арифметической прогрессии числовой последовательности. Где кол-во элементов и сами элементы вводятся с клавиатуры?

var
i,p,k,r,s:integer;
mas: array[1..100] of integer;
begin
s:=0;
read(k);
for i:=1 to k do
read(mas[i]);

r:=mas[2]-mas[1];

for i:=1 to k do
s:=s+mas[i];

writeln(raznost progressii=, r, , summa elementov progressii=, s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку