Написать программу в Паскале.
По заданному числу N определите знак числа.
Формат входных данных:
Во входном файле input.txt записано одно целое число N (-10000<=N<=10000)
Формат выходных данных:
если заданное число положительное, то в выходной файл output. txt выведите квадрат этого числа. Если заданное число отрицательное, то вывелите модуль этого числа. Если же заданное число - нуль , то и вывести надо нуль.
Примеры:
input.txt output.txt
5 25
-5 5
0 0

Это если алгоритм выполнить дословно:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, input.txt); Reset(f1);
  Assign(f2, output.txt); Rewrite(f2);
  Readln(f1, n);
  if n < 0 then Writeln(f2, abs(n))
  else
  if n = 0 then Writeln(f2, 0)
  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.

А это, если учесть, что модуль нуля равен нулю:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, input.txt); Reset(f1);
  Assign(f2, output.txt); Rewrite(f2);
  Readln(f1, n);
  if n <= 0 then Writeln(f2, abs(n))
  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку