Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Входные данные
Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей.
Примеры
Входные данные
5
1 2 3 4 5
Выходные данные
0
Входные данные
5
1 5 1 5 1
Выходные данные
2
Var i,num,s:integer;
arr:array of integer;
begin
readln(num);
setlength(arr,num);
for i:=0 to num-1 do begin
read(arr[i]);
if i>1 then begin
if (arr[i-2]
end;
writeln(,s);
end.
Оцени ответ
