Информатика. Составить программу "Электронный калькулятор".
Программа должна предложить ввести два действительных числа и знак арифметической операции (+,-,*,/).Произвести требуемое вычисление и вывести результат операции.

varx,y,z: real;sign: char;beginwhile True do beginwrite(sign: ); readln(sign);if sign = 0 then break;if sign in [+,-,*,/] then beginwrite(x=); readln(x);write(y=); readln(y);case sign of+: begin z := x + y; writeln(z:5:2) end;-: begin z := x - y; writeln(z:5:2); end;*: begin z := x * y; writeln(z:5:2); end;/: if y <> 0 then beginz := x / y;writeln(z:5:2)endelsewriteln(Division by zero!);end;endelse writeln(Bad sign!)end;end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку