Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4×4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец. Разрешается вывести пустой столбец после последнего флага. Внутри каждого флага должен быть записан его номер — число от 1 до n.
входные данные
1
выходные данные
+___
|1 /
|__
|
Паскаль. Нужно использовать фор.

Var 
 i,n:integer;
begin 
  read(n); 
  for i:=1 to n do   
   write(+___ ); 
  writeln; 
  for i:=1 to n do 
    write(|,i, / ); 
  writeln; 
  for i:=1 to n do   
   write(|__ ); 
  writeln; 
 for i:=1 to n do 
    write(|    );
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку