Алгоритм вычисления значений функций F(n) и G(n), где n – натуральное число, задан следующими соотношениями:
F(1) = 1; G(1) = 1;
F(n) = F(n–1) – 2*G(n–1),
G(n) = F(n–1) + 2*G(n–1), при n >=2
Чему равно значение величины G(5)-F(5)?

Значение величины G(5)-F(5) равно 12.
В процессе вычисления каждая из функций вызывается по 31 разу, поэтому вычисление вручную очень утомительно.
Была составлена следующая программа, которая и выдала результат:

function G(n: integer): integer; forward;

function F(n: integer): integer;
begin
  if n = 1 then F := 1
  else F := F(n - 1) - 2 * G(n - 1)
end;

function G(n: integer): integer;
begin
  if n = 1 then G := 1
  else G := F(n - 1) + 2 * G(n - 1)
end;

begin
  Writeln(G(5) - F(5))
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку