Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от -20 до 20. Написать программу, которая выводит среднюю температуру среди дней, когда была оттепель.

Var a,b,i:integer;
n:real;
mass:array[1..31] of integer;
begin
for i:=1 to 31 do begin
mass[i]:=random(40)-20;
if mass[i]>0 then begin
b:=b+1;
a:=a+mass[i];
end;
end;
writeln(Полученные значения);
for i:=1 to 31 do
write(mass[i]:4);
n:=a/b;
writeln;
writeln(Средняя температура равна ,n:3:1);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку