Написать программу на языке Си
.1. Подсчитать количество прописных букв в строке.
2. Удалить из строки самое длинное слово.
Написать програму которая считывает текст с клавиатуры, находит самое длинное число и определяет, сколько раз оно встретилось в тексте.
Код C++
#include
#include
#include
#include
void main();
{clrscr();
char s[50];
char s1{}=" ";
char *p;
char *q;
char e[50];
int g,a;
cout<<"vvedite tekst:"<
p=strtok(s,s1);
while(p)
{if(*p== )
p=strtok(s,s1);
g=strlen(p);
cout<
*e=*p;
}
p=strtok(NULL,s1);
}
puts(e);
cout<
}
Оцени ответ
