Дан массив E(10). Составить программу обработки массива:
1. Положительные элементы массива заменить нулями.
2. Определить число элементов массива равных 5.
3. Найти сумму чисел, неравных 3.
Все это должно быть в одной задаче, решите плиз качественно, даю много баллов.
Ах, да, все это на языке паскаль.
var sum,c,i,l:integer;
E:array[1..10] of integer;
begin
writeln(Введите числа);
for i:=1 to 10 do begin
read(e[i]);
if e[i]>0 then e[i]:=0;
if e[i]=5 then l:=l+1;
if e[i]<> 3 then sum:=sum+e[i];
end;
writeln(Полученный массив);
for i:=1 to 10 do
write(e[i]:4);
writeln;
writeln(Сумма чисел, не равных трем равна ,sum);
writeln(Число элементов массива, равных пяти равна ,l);
end.
Оцени ответ
