Помогите пожалуйста написать программу на паскале!!!
Даны целые числа н (н>0), a1,....,aн. Все члены последовательности a1,....,aн, предшествующие первому по порядку наименьшему члену домножить на этот наименьший член.

Var n,a,b,i,min:integer;
mass:array[1..100000] of integer;
begin
writeln(Введите кол-во элементов массива);
read(n);
writeln(Введите числа);
for i:=1 to n do// задаем массив пока i не станет равно n (i:=i+1 )
read(mass[i]);//считываем массив с индексом i
min:=mass[1];// обозначаем первый элемент массива за первый
b:=1;// индекс от первого элемента массива
for i:=1 to n do//цикл задаем массив пока i не станет равно n (i:=i+1 )
if mass[i]b:=i;// обозначаем индекс
min:=mass[i];// обозначаем новый минимальный массив
end;
for i:=1 to b-1 do// задаем массив пока i не станет равно b-1 (i:=i+1 ); и еще b-1 значит чтобы само число b не входило в цикл
mass[i]:=mass[i]*mass[b];// домножаем на меньший массив
writeln(Полученный массив);// вывод массива
for i:=1 to n do
write(mass[i]:6);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку