Дан массив Y(11). Составить программу
обработки массива:
1. Найти сумму отрицательных элементов массива среди элементов, стоящих на нечетных местах.
2. Заменить все элементы, стоящие на нечетных местах, значениями их квадратов.
3. Подсчитать количество 1, стоящих на четных местах.
Все это должно быть в одной задаче, решите плиз качественно, даю много баллов.
Ах, да, все это на языке паскаль.
Var Y: array [1..11] of integer;
var i, sum, n: integer;
begin
randomize;
for i:=1 to 11 do begin
Y[i]:=-10+random (21);
write (Y[i], );
end;
sum:=0;
for i:=1 to 11 do begin
if (i mod 2<>0) and (Y[i]<0) then sum:=Y[i]+sum; //№1
if i mod 2<>0 then Y[i]:=Y[i]*Y[i]; //№2
if (i mod 2=0) and (Y[i]=1) then inc (n); //№3
end;
writeln;
writeln (Сумма =, sum);
writeln (Количество 1 на четных местах =, n);
end.
Оцени ответ
