Дан массив А(14): 1,-3,6,-5,-2,8,-9,14,-24,15,17,12,17,4
Составить программу обработки массива:
1) Найти максимальный элемент среди элементов, стоящих на четных местах.
2) Удалить минимальный элемент массива.
3) Поменять местами первый и последний элементы массива.
4) Вставить в середину массива элемент равный 10.
Решить на паскале, без рандома, с этими конкретными значениями. Спасибо!

Program test;
const
  n=14
var
  i, i1, x, s, mx : integer;
  t: string;
  m1: array [1..n] of integer;
begin
  for i := 1 to n do            //ввод данных
  begin
    writeln (введите очередной элемент --> );
    read (x);
    m1[i] := x;
  end;
 
  mx := m1[2];                  // поиск максимального элемента
  for i := 4 by 2 to n do
  begin
     x := m1[i];
     if (x > mx) then mx := x;
  end;
  writeln(максимальный элемент ,mx);
 
  mx := m1[1];                  // поиск минимального элемента
  for i := 2 to n do
  begin
     x := m1[i];
     if (x < mx) then
     begin
         mx := x;
         i1 := i;
      end;
  end;
  for i := i1 to (n-1) do m1[i] := m1[i+1];      //удаление минимального элемента
 
  x := m1[1];                         //меняем местами 1-й и последний элементы
  m1[1] := m1[n-1];
  m1[n-1] := x;
 
  for i := (n-1) by (-1) to 8 do m1[i-1] := m1[i];         //вставляем. освобождаем место
  m1[7] := 10;                                                //вставили.
 
   for i := 1 to n do  writeln(i, --> , m1[i]);               //результат
end;
end.



Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку