Напишите программу для решения следующей задачи в qbasic
Девятиклассники участвовали в викторине по математике. Необходимо было
ответить на 20 вопросов. Победителем викторины считается участник,
правильно ответивший на наибольшее количество вопросов. На сколько
вопросов победитель ответил правильно? Если есть участники викторины,
которые не смогли дать правильный ответ ни на один из вопросов, выведите
YES, иначе выведите NO. Гарантируется, что есть участники, правильно
ответившие хотя бы на один из вопросов.
Программа получает на вход число участников викторины N (1 ≤ N ≤ 50),
затем для каждого участника вводится количество вопросов, на которые
получен правильный ответ.
Пример работы программы:
Входные данные
4
15
12
0
17
Выходные данные
17
YES
var
i, k,n, max: integer;
f:boolean;
begin
readln(k);
for i := 1 to k do
begin
readln(n);
if (i = 1) or (max < n) then
max := n;
f:=f or (n=0);
end;
writeln(max, , f);
end.
Оцени ответ
