Царевна-лягушка съедает ежедневно на 20% комаров больше, чем в предыдущий день, и еще 2 комара. Через сколько дней количество съеденных комаров в день превысит 30, если в первый день было съедено 12 комаров. Воспользовавшись словесным алгоритмом, заполните шаблон блок-схемы и составьте программу для решения задачи.

var mosquito :integer;
day, sum :integer;
BEGIN
day := 1;
mosquito := 12;
sum := 0;
repeat
mosquito := Trunc(mosquito * 1.2) + 2;
day := day +1;
sum := sum + mosquito;
writeln(  day  mosquito sum);
until sum > 100;
writeln(day);
end

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку