Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет. Значение выводить с точностью до десятых.
Нужно написать программу на языке PaskalABC.
Вот что получилось у меня, но пишет, что на 12 строке "Встречено :=, а ожидался оператор"

Uses crt;
var
     n,s,k: integer;
begin     
     s:=0;     
     k:=0;     
     repeat           
          readln(n);           
          if (n<>0) and (n mod 8 = 0) then           
          begin               
               s:=s+n;               
               inc(k);           
          end;     
          until n=0;     
          if (s<>0) then
               writeln(s/k:0:1)
          else writeln(NO);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку