Нужна помощь по информатике. Задача:
Написать программу вычислить произведение из двух наибольших введенных с клавиатуры чисел.( в ПАСКАЛЕ). Проще говоря, у меня есть три числа, я должен ввести их, и два наибольших из них должны перемножаться. Нужно написать программу используя условные операторы. Заранее спасибо.

Var m: array [1..3] of real;
var i, imin, imax: integer;
var num, pro: real;
begin
imin:=1;
imax:=1;
for i:=1 to 3 do read (m[i]);
for i:=1 to 3 do  
begin 
if m[i]if m[i]>m[imax] then imax:=i; 
end;
num:=m[1]+m[2]+m[3]-m[imin]-m[imax];
pro:=num*m[imax];
write (pro);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку