Определите значение переменных х и у после выполнения фрагмента алгоритма:
а) Даны х и у
у:=у-х
х:=х-2
х больше у?
Если да, то конец
Если нет, то снова:
у:=у-х
х:=х-2
б) Даны х и у
у:у+х
х:=х-2
х=0?
Если да, то конец
Если нет, то снова:
у:=у+х
х:=х-2
а)
var x, y: integer;
begin
write(Введите x: );
readln(x);
write(Введите y: );
readln(y);
y := y - x;
x := x - 2;
if x < y then
begin
y := y - x;
x := x - 2;
end;
writeln(x = , x);
writeln(y = , y);
end.
б)
var x, y: integer;
begin
write(Введите x: );
readln(x);
write(Введите y: );
readln(y);
y := y + x;
x := x - 2;
if x <> 0 then
begin
y := y + x;
x := x - 2;
end;
writeln(x = , x);
writeln(y = , y);
end.
Оцени ответ
