Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата
Var
a,r,rvp,rop:real;
begin
Write(Введите сторону квадрата и радиус окружности: );
Readln(a,r);
rvp:=a/2; rop:=a*sqrt(2)/2;
if r
if r=rvp then Writeln(Введен радиус вписанной окружности)
else
if r
if r=rop then Writeln(Введен радиус описанной окружности)
else Writeln(Окружность расположена вне описанной)
end.
Тестовое решение:
Введите сторону квадрата и радиус окружности: 8 5
Окружность расположена между вписанной и описанной
Оцени ответ
