Помогите,прошу,умоляю!
Составить программу на языке програмирования Паскаль.
1) Пойдет ли сундук с соровищами со сторонами а,в,с в иллюминатор затонувшего корабля диаметром д.
2) Имеется треугольник с координатами(0,0)(5,0)(0,5). Попадает ли точка А(х,у) внутрь либо на границы этого треугольника. Ответ вывести в форме Да или Нет.

Var
  a,b,c,d,x,y:real;
begin
  Write(Введите размеры сторон сундука -> ); Readln(a,b,c);
  Write(Введите диаметр иллюминатора -> ); Readln(d);
  if a    x:=a;
    if b  end
  else begin
    x:=b;
    if a  end;
  if (sqr(x)+sqr(y)  else Writeln(Сундук нельзя вытащить)
end.

Тестовое решение:
Введите размеры сторон сундука -> 3 5 3.99
Введите диаметр иллюминатора -> 5
Сундук можно вытащить

**********************
Условие попадания точки A(x,y) внутрь треугольника описывается как
begin {cases} xge 0  yge 0  yle 5-x end {cases} Rightarrow  (xge0) land (yge0) land (yle 5-x)

var
  x,y:real;
begin
  Write(Введите координаты x и y точки -> ); Readln(x,y);
  if (x>=0) and (y>=0) and (y<=5-x) then Writeln(Да)
  else Writeln(Нет)
end.

Тестовое решение:
Введите координаты x и y точки -> 3 2.5
Нет

Введите координаты x и y точки -> 2.1 2.8
Да



Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку