Ребята,помогите,очень нужно.
В классе 20 учеников писали контрольную работу по физике. Оценки задаются как целые случайные числа в интервале от 2 до 5. Напишите программу,которая подсчитывает средний балл за контрольную и определяет количество учеников, получивших балл ниже среднего.
Const
n = 20;
var
x: array[1..n] of integer;
i, k, s: integer;
c:real;
begin
Randomize;
Writeln(Полученные баллы);
s := 0;
for i := 1 to n do
begin
x[i] := Random(4)+2;
Write(x[i]:2);
s:=s+x[i];
end;
Writeln;
c:=s/n;
k:=0;
for i := 1 to n do if x[i]
end.
Тестовое решение:
Полученные баллы
5 2 5 2 5 3 4 2 2 2 2 4 5 2 4 4 5 5 4 4
Средний балл: 3.55, количество получивших баллы ниже него: 8
Оцени ответ
