Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и определение максимального (наи
большего) из введёных чисел.Используйте оператор repeat.
-------------------------------------------------------------
Решить в паскале
напишите программу вычисления наибольшего общего делителя двух натуральных чисел
а) использовать оператор repeat
б)использовать оператор while

Var
max,a : integer;
begin
readln(a);
max := a;
repeat
readln(a);
if (a > max) and (a <> 0) then
max := a;
until a = 0;
writeln(max);
readln;
end.

var
max,a : integer;
begin
readln(a);
max := a;
while (a<>0) do
begin
readln(a);
if (a > max) and (a <> 0) then
max := a;
end;
writeln(max);
readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку