Составить программу, содержащую ветвления и определяющую, принадлежит ли точка с координатами (X,Y) заштрихованной области.
Помогите, пожалуйста

Uses crt;
var x,y:integer;
begin
     readln(x,y);
     if (y<=7) and (y>=1) and (y<=(2*x+13)) and (y<=(-2*x+15)) then
          writeln(yes)
     else writeln(no);
end.
__________
UPD: Чтобы найти уравнения прямых достаточно подставить координаты вершин в уравнение прямой y=kx+b и решить две системы, в каждой из которых по два уравнения. 
Распишу подробнее.
Рассмотрим прямую, ограничивающую нашу фигуру слева. Возьмем две координаты (вершины), через которые она проходит - (-3,7) и (-6,1). Составим систему:
 left { {{1=-6k+b} atop {7=-3k+b}} right.  left { {{b=1+6k} atop {7=-3k+1+6k}} right.  left { {{b=1+6k} atop {k=2}} right.  left { {{k=2} atop {b=13}} right.
Получили уравнение прямой: y=2x+13.
Аналогичные рассуждения для второй прямой.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку