Написать программу, определяющую по координатам трёх точек длины биссектрис треугольника, если таковой существует. (PascalABC)
Var x:Array[1..3] of integer;// координаты точекy:Array[1..3]of integer;// координаты точекs:Array[1..3]of real; // расстояние между точками b:Array[1..3]of real; // длина бессектрисы p: real; beginfor var i:= 1 to 3 dobegin write(Введите координаты , i , точки); readln(x[i], y[i]); end; writeln(Начало расчетов); for var i:= 1 to 3 dobegin
if (i < 3) then begin s[i] := sqrt((x[i]-x[i+1])* (x[i]-x[i+1]) + (y[i]-y[i+1])* (y[i]-y[i+1])); p := p + s[i]; end else begin s[i] := sqrt((x[i]-x[1])* (x[i]-x[1]) + (y[i]-y[1])* (y[i]-y[1])); p := p + s[i]; end;
writeln(Расстояние между , i , и , i+1, точками = , s[i]); end; p := p /2; writeln(полупериметр = , p); for var i:= 1 to 3 do beginif (i = 1) then b[i] := 2* sqrt(s[1]*s[2]*p * (p - s[3]))/(s[1]+s[2]);if (i = 2) then b[i] := 2* sqrt(s[2]*s[3]*p *(p - s[1]))/(s[2]+s[3]);if (i = 3) then b[i] := 2* sqrt(s[3]*s[1]*p *(p - s[2]))/(s[3]+s[1]); writeln(Длина , i, бессиктрисы , b[i]); end;end.//определяющую по координатам трёх точек длины биссектрис треугольника,//если таковой существует. (PascalABC)
