Дано натуральное число N. Написать программу, выводящую последовательность чисел 1,2,3....,N (решить с помощью while)
по возможности решите еще и
Дано n натуральных чисел. Написать программу, вычисляющую их среднее арифметическое (число n вводится перед всеми остальными числами )
Дано натуральное число n. Написать программу, выводящую степени двойки от первой до n-й 2,4,8,6 ...

Var n,i:integer;
begin
write(N= );
read(n);
i:=1;
while i<=n do
begin
writeln(i);
i:=i+1;
end;
end.

var n,i,sum:integer;
cp:real;
begin
write(N= );
read(n);
i:=0;
while ibegin
i:=i+1;
sum:=sum+i;
end;
cp:=sum/i;
writeln(Среднее значение натуральных чисел до N равно ,cp);
end.

var n,i,b,m:integer;
begin
write(N= );
read(n);
b:=2;
i:=0;
write(b);
writeln;
while ibegin
i:=i+1;
b:=b*2;
writeln(b);
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×