ПОМОГИТЕ ОЧЕНЬ СРОЧНО НУЖНО Даны массивы A и B, содержащие длины 10 сторон прямоугольников. Написать программу для вычисления площадей этих прямоугольников и определения прямоугольника с наибольшей площадью. Вывести на экран индекс, длины сусторон и площадь искомого прямоугольника.
Const
n = 10;
var
a,b: array[1..n] of integer;
i, s, imax, smax: integer;
begin
Randomize;
Writeln(Элементы массива A);
for i := 1 to n do
begin
a[i] := Random(30)+5;
Write(a[i]:3);
end;
Writeln;
smax:=0; imax:=0;
Writeln(Элементы массива B);
for i := 1 to n do
begin
b[i] := Random(30)+5;
Write(b[i]:3);
s:=a[i]*b[i];
if smax end;
Writeln;
Writeln(Прямоугольник номер ,imax, имеет максимальную площадь ,
a[imax],x,b[imax],=,smax)
end.
Тестовое решение:
Элементы массива A
31 30 34 9 12 11 11 24 34 29
Элементы массива B
18 16 15 16 19 22 24 22 25 5
Прямоугольник номер 9 имеет максимальную площадь 34x25=850
Оцени ответ
