Срочно! Нужно решить задачу по информатике. На каждый день рождения мне дарят деньги.В первый год мне подарили 1$. В каждый следующий мне удваивали подарок и прибавляли столько $, сколько лет исполнилось. К какому дню рождения подарок превысит 100$?
1) Написать программу для paskal
2) Составить блок схему
3) Составить трассировочную таблицу

Program chik;
var w,q,s,n,i,h:longint;
begin
s:=1;
q:=1;
h:=1;
w:=1;
while w<100 do
begin
q:=q+1;
h:=h+1;
s:=s*2+q;
w:=w+s;
writeln(w);
end;
writeln(w, ,h);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку