Написать программу (Процедуру), выводящую квадраты чисел от a до b (a,b вводятся с клавиатуры);
И всё-таки, мне кажется, что надо вывести именно полные квадраты чисел в указанном диапазоне, иначе формулировка была бы типа: "Возведите в квадрат все числа в указанном диапазоне". Код на паскале:
var a, b, i, j : integer;
begin
readln(a, b);
for i := a to b do
begin
j := round(sqrt(i));
if j*j = i then writeln(i);
end;
end.
Оцени ответ
