Помогите решить пожалуйста даю 20 баллов!!!
Дано целое число N (0<=N<=9). Написать программу, вычисляющую сумму всех двузначных чисел(в записи которых нет цифры N)
Даны целые числа A и B.Написать программу, подсчитывающую сумму двузначных чисел, у которых либо первая цифра равна A, либо вторая цифра равна B.
Написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N
Все через While

Program tak;
var a,b,c,N:integer;
begin writeln(введите число N (0<=N<=9) );
 readln(N);
 b:=0; 
for a:=99 downto 10 do  begin 
  if (N <> a div 10) and (N <> a div 10) then 
  b:=a+b; 
 end;
 writeln(b);
end.
эт первая

program tak2;
var a,b,c,d:integer;
begin writeln(введите два числа );
 readln(a,b);
 d:=0; 
for c:=99 downto 10 do  begin 
  if (a = c div 10) or (b = c mod 10) then 
  d:=c+d;
  end;
 writeln(d);
end.
эт вторая

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку