Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в данном числе.
09

Vari,a,k,m:integer;         
        begin                   
           Repeat                         
              writeln( ВВедите число);                         
                  readln(a);  k:=0;                       
                          while a>0 do                             
                              begin                                   
                                  m:=a mod 10;                                   
                                  k:=k+1;                                   
                                  a:=a div 10;                             
                             end;                             
             Until k<=5;                   
      writeln(k);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку