Чему будет равно значение переменной p при a=4 и n=3 после выполнения программы
Program Test
Var a, p:integer;
i, n:real;
Begin
Write (Введите два натуральных числа)
Readln (a,n);
p:=1
for i:=1 to n do
p:=p*a;
Writeln (p=,p)
End.

На самом деле, программа и правда из рук вон криво написана, начиная от простой понятности и лаконичности и заканчивая работоспособностью.

Рабочий вариант, если я правильно понял ваш код:
Program Yolo;
Uses Crt;
Var a: integer; i, n: byte; p: longint;
Begin
  ClrScr;
 Writeln(Введите число и его степень.);
 Readln(a, n);
 p:=1;
 For i:=1 to N do
  p:=p*a;
 Writeln(Получившиеся число: , p);
 Readln;
End.

4 в степени 3 будет равен 64.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку