Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35;35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов; 4) заменить числом 5 элементы, стоящие на четных местах, и числом 0 - элементы, стоящие на нечетных местах, вывести в строку получившийся массив.

Program t1;
const
  j = 18
var
  n,j, i, s,s1: integer;
  mas: array [1..j] of integer;
begin
    randomize;
    writeln (сгенерированный масив: );
    for i := 1 to j do
    begin
      mas[i] := random (70) - 35;
      write (mas[i]);
    end;
   
    s:= 0; s1:=0;
    for i := 1 to j do
    begin
      if (i mod 2 =0) then s := s+mas[i];              //сумма четных элементов
      if (mas[i] >= 0) then s1 := s1 + mas[i];       //сумма неотрицательных элементов
    end;  
    writeln (среднее арифметическое четных элементов:  , s/18);
    writeln (сумма неотрицательных элементов:  , s1);
    writeln (массив после замены элементов:  );    
    for i := 1 to j do
    begin  
       if (i mod 2 =0) then mas[i] := 5 else mas[i] := 0;
      write (mas[i]); 
    end;       
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку