Улитка ползёт по вертикальному шесту высотой h метров, поднимаясь за день на a метров, а за ночь спускаясь на b метров. На какой день улитка доползёт до вершины шеста? Программа получает на вход натуральные числа h, a, b и должна вывести одно натуральное число. Гарантируется, что a>b. При решении этой задачи нельзя пользоваться условной инструкцией if и циклами. Примеры Входные данные 10 3 2 Выходные данные 8
uses crt;
var
a,b,h,h1,k:integer;
begin
read(h,a,b);
h1:=h-a;
k:=a-b;
write(1+h1 div k+(h1 mod k+k-1) div k);
end.
Оцени ответ
