Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают 30 000.
Программа должна вывести одно число: количество трёхзначных чисел, кратных 4.
Напишите программу в паскале пожайлуста.


var
    i, count, number: integer;

begin
    count := 0;
    i := 0;
    writeln(Введите последовательность чисел);
    repeat
        readln(number);
        if (number >= 100) and (number <= 999) and (number mod 4 = 0) then
            count := count + 1;
        i := i + 1
    until (number = 0) or (i >= 1000);
    
    writeln(Кол-во 3значных чисел кратных 4 =, count);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку